webmin mail configuration

Subject:

after following the instructions from webminhttp://doxfer.webmin.com/Webmin/Postfix_Basic_Configuration

I had to go into the postfix config file main.cf and enable inet_interfaces = all

in dovecot Mail Files mail file location is detect automatically that never works

  • use Inbox and folders in ~/Maildir

SELINUX will prevent first login for mail and the creation of Maildir in the home/*user* folder.  you need to disable selinux or permissive and reboot

2016-04-24 19:17:04gstlouis

moved over my old mail files to /home/gstlouis that needed chown onwership back to gstlouis:gstlouis
ex.
chown -R gstlouis:gstlouis ./

gstlouis
vote
2016-04-24 19:48:55

there was also a missing auth problem from dovecot in 
/etc/dovecot/conf.d/10-master.conf
need to enable


  •   # Postfix smtp-auth
      unix_listener /var/spool/postfix/private/auth {
        mode = 0666
        user = postfix
        group = postfix
      }
gstlouis
vote
2016-04-24 19:50:10

refer: https://www.howtoforge.com/postfix-dovecot-warning-sasl-connect-to-private-auth-failed-no-such-file-or-directory

 

 

From: easyorange

I had exactly the same problem and the instructions on this page did not help at all. In fact, the instructions on postfix site did not help either.

On our system, here's what helped -

 chown postfix:postfix /var/spool/postfix/private/auth

 chmod 666 /var/spool/postfix/private/auth

 And, in /etc/dovecot/conf.d/10-master.conf (or /usr/local/etc/dovecot/conf.d/10-master.conf) set the config like this -

  unix_listener auth-userdb {

    mode = 0666

    user = postfix

    group = postfix

  }

 

  # Postfix smtp-auth

  unix_listener /var/spool/postfix/private/auth {

    mode = 0666

  }  

 Lastly, 

/etc/init.d/dovecot restart

 

gstlouis
vote
2016-04-24 20:14:14