arch linux kernel 4.7 ati radeon issues

Subject:

 

 

Downgrading the kernel

If you are unable to boot after a kernel update, then you can downgrade the kernel via a live CD. Use a fairly recent Arch Linux installation medium. Once it has booted, mount the partition where your system is installed to /mnt, and if you have /boot or/var on separate partitions, mount them there as well (e.g. mount /dev/sdc3 /mnt/boot). Then chroot into the system:

# arch-chroot /mnt /bin/bash

Here you can go to /var/cache/pacman/pkg and downgrade the packages. At least downgrade linuxlinux-headers and any kernel modules. For example:

# pacman -U linux-3.5.6-1-x86_64.pkg.tar.xz linux-headers-3.5.6-1-x86_64.pkg.tar.xz virtualbox-host-modules-4.2.0-5-x86_64.pkg.tar.xz

Exit the chroot (with exit), reboot and you should be done.

2016-10-17 13:01:55gstlouis

after downgrade 
 

Enable early KMS

Tip: If you have problems with the resolution, Kernel mode setting#Forcing modes and EDID may help.

Kernel mode setting (KMS) is supported by the radeon driver and is mandatory and enabled by default.

KMS is typically initialized after the initramfs stage. It is possible, however, to enable KMS during the initramfs stage. To do this, add the radeon module to the MODULES line in /etc/mkinitcpio.conf:

MODULES="... radeon ..."

still could not browse

gstlouis
vote
2016-10-18 17:13:37