centos install upgrade to php 5.6

Subject:

Cheers guys - I had already found a solution before I read your posts, so used the method from this site

https://www.mojowill.com/geek/howto-install-php-5-4-5-5-or-5-6-on-centos-6-and-centos-7/

In a nutshell I did the following:

CentOS 6 installation

wget http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm

Enable the repo Modify the /etc/yum.repos.d/remi.repo file

[remi] name=Les RPM de remi pour Enterprise Linux 6 - $basearch #baseurl=http://rpms.famillecollet.com/enterprise/6/remi/$basearch/ mirrorlist=http://rpms.famillecollet.com/enterprise/6/remi/mirror enabled=1 gpgcheck=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

Then in the same file there is a section for php56 and I set the enabled flag from 0 to 1 and voila! Next time I ran the yumo install command it all went through without any errors.

e.g

sudo yum install php php-gd php-mysql php-mcrypt

2016-12-02 10:06:16gstlouis

this worked on centOS 6.8 final

virtualmin was installed

gstlouis
vote
2017-01-23 14:07:01

installed a new cloudmin, version was php 5.3 had to upgrade.

followed the link above and it worked fine

had to remove the old php:

  • didn't have much install it only remove 5.3 one liner

yum remove php

commands:

69  wget http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
70  wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
72  rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm
73  vim /etc/yum.repos.d/remi.repo
74  yum install php php-gd php-mysql php-mcrypt

gstlouis
vote
2017-01-20 09:02:39

this is a new install packages string that include the multi byte string

yum install php php-gd php-mysql php-mcrypt php-mbstring

gstlouis
vote
2017-01-23 14:50:44